Development: MyBB Conversation System
#21
Ahh! Actually; we're using MariaDB. That could be it?
Reply
#22
MariaDB should be fine, I use it here too.

In your inc/config.php file, look for this line:

PHP Code:
$config['database']['type'] = 'mysql'

Try changing it to the following:

PHP Code:
$config['database']['type'] = 'mysqli'

MyBB has several database "adapters" that are used to connect to MySQL. One is simple "MySQL" and the other is "MySQL Improved (MySQLi)". The latter is preferred and is the one the plugin currently expects.
Reply
#23
Doing that gives

Code:
Error Message:
MyBB was unable to load the SQL extension. Please contact the MyBB Group for support
Reply
#24
Ah, looks like your host doesn't support MySQLi Sad What version of PHP are you on?
Reply
#25
PHP version: 5.4.29 Happy.

I'll talk to my host about getting MySQLi for mariadb.
Reply
#26
Odd. The old mysql library is deprecated and that's a pretty new version of PHP that you've got.
Reply
#27
I did ask my host about mysqli. They offered to downgrade us to MySQL 5 or MariaDB 5 because MySQLi is not supported in MariaDB ten apparently.
euan likes this post
Reply
#28
(06-09-2014, 11:29 PM)ashkir Wrote: I did ask my host about mysqli. They offered to downgrade us to MySQL 5 or MariaDB 5 because MySQLi is not supported in MariaDB ten apparently.

Strange, I am using MariaDB 10 and the MySQLi extension with no problem on my servers... MariaDB 10 is binary compatible with MySQL 5.6/5.5 so the PHP mysqli extension should work with it. Who's your host?
Reply
#29
ASmallOrange.
Reply
#30
ASO have always been pretty good with me, so I'm surprised you're having such problems Sad
Reply